Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(1255)

Issue 7139043: Add option to ignore small pixel diffs for --validate. By default, right now we will default to max… (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
11 years, 8 months ago by edisonn
Modified:
11 years, 8 months ago
Reviewers:
EricB, reed1
CC:
skia-review_googlegroups.com
Base URL:
http://skia.googlecode.com/svn/trunk/
Visibility:
Public.

Description

Add option to ignore small pixel diffs for --validate. By default, right now we will default to max diff of 256, which means that for now we report all pixels that are not as expected and we do not error out. Ideally we will decrease the value of max diff to something that does not have visual impact, e.g. 10, then we will report small changes with the intensity under 10, but we will error out for anything larger. Committed: https://code.google.com/p/skia/source/detail?r=7218

Patch Set 1 #

Patch Set 2 : #

Total comments: 2

Patch Set 3 : #

Total comments: 4
Unified diffs Side-by-side diffs Delta from patch set Stats (+58 lines, -20 lines) Patch
M tools/render_pictures_main.cpp View 1 2 11 chunks +58 lines, -20 lines 4 comments Download

Messages

Total messages: 5
edisonn
11 years, 8 months ago (2013-01-16 14:12:23 UTC) #1
EricB
LGTM with parameter validation request. https://codereview.appspot.com/7139043/diff/1002/tools/render_pictures_main.cpp File tools/render_pictures_main.cpp (right): https://codereview.appspot.com/7139043/diff/1002/tools/render_pictures_main.cpp#newcode573 tools/render_pictures_main.cpp:573: Please add a condition ...
11 years, 8 months ago (2013-01-16 14:30:35 UTC) #2
edisonn
https://codereview.appspot.com/7139043/diff/1002/tools/render_pictures_main.cpp File tools/render_pictures_main.cpp (right): https://codereview.appspot.com/7139043/diff/1002/tools/render_pictures_main.cpp#newcode573 tools/render_pictures_main.cpp:573: On 2013/01/16 14:30:35, EricB wrote: > Please add a ...
11 years, 8 months ago (2013-01-16 14:46:20 UTC) #3
reed1
command-line style question Is this optional extra command+value the clearest, or should we always require ...
11 years, 8 months ago (2013-01-16 14:52:13 UTC) #4
edisonn
11 years, 8 months ago (2013-01-16 15:46:50 UTC) #5
Message was sent while issue was closed.
1. I prefer to have an optional parameter for --validate, in this way we can be
clear about what is the expected maximum diff, rather than having to dig into
buildbot configuration files and scripts

new cl uploaded at https://codereview.appspot.com/7137046

https://codereview.appspot.com/7139043/diff/4001/tools/render_pictures_main.cpp
File tools/render_pictures_main.cpp (right):

https://codereview.appspot.com/7139043/diff/4001/tools/render_pictures_main.c...
tools/render_pictures_main.cpp:178: 
what about using SKColor with SkBitmap::getColor(x,y) ?


On 2013/01/16 14:52:13, reed1 wrote:
> For clarity, we need to either
> - Change these parameter types to SkPMColor, and use the macros in
SkColorPriv.h
> to access the components (e.g. SkGetPackedR32)
> 
> or
> 
> - add a big comment documenting that we are treating SkPMColors as SkColors,
but
> that its OK, because we treat all components the same
> 
> or
> 
> - use a generic set of getters that don't claim to be color-type specific.
e.g.
> 
> getbyte(uint32_t value, int index) {
>     return (value >> (index * 8)) & 0xFF;
> }

https://codereview.appspot.com/7139043/diff/4001/tools/render_pictures_main.c...
tools/render_pictures_main.cpp:189: int diffs[256];
On 2013/01/16 14:52:13, reed1 wrote:
> int diffs[256] = { 0 }; or {};  ?
> 
> or
> 
> sk_bzero(diffs, sizeof(diffs));

Done.
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b