Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(33)

Issue 545370043: Switch to Python 3.x (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
3 months, 1 week ago by hahnjo
Modified:
1 month, 3 weeks ago
Reviewers:
lemzwerg
CC:
lilypond-devel_gnu.org
Visibility:
Public.

Description

Switch to Python 3.x Find and require at least Python 3.5 which will allow us to address some deprecation warnings, most notably about the 'imp' module. The major version 3.5 was first released in September 2015 and should be available in all major distributions, including Ubuntu LTS 16.04 and 18.04 as well as CentOS/RHEL 7.x and 8.x.

Patch Set 1 #

Patch Set 2 : Rebase #

Unified diffs Side-by-side diffs Delta from patch set Stats (+7 lines, -5 lines) Patch
M aclocal.m4 View 1 2 chunks +6 lines, -4 lines 0 comments Download
M configure.ac View 1 1 chunk +1 line, -1 line 0 comments Download

Messages

Total messages: 4
lemzwerg
Mhmm, I'm not happy with that. What I can imagine is to *prefer* Python 3.x ...
3 months, 1 week ago (2019-12-20 00:12:25 UTC) #1
hahnjo
On 2019/12/20 00:12:25, lemzwerg wrote: > Mhmm, I'm not happy with that. What I can ...
3 months, 1 week ago (2019-12-20 08:51:56 UTC) #2
lemzwerg
> As I said on the mailing list multiple times, it's actually > a ton ...
3 months, 1 week ago (2019-12-20 09:49:46 UTC) #3
hahnjo
2 months, 1 week ago (2020-01-22 09:29:28 UTC) #4
Rebase
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b