Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(7821)

Issue 284080043: fixed READ/WRITE_TLS_SLOT bug on ARM

Can't Edit
Can't Publish+Mail
Start Review
Created:
8 years, 3 months ago by zhaoqin
Modified:
8 years, 3 months ago
Reviewers:
bruening
CC:
dynamorio-devs_googlegroups.com
Visibility:
Public.

Description

Commit log for first patchset: --------------- fixed READ/WRITE_TLS_SLOT bug on ARM - change 'idx * sizeof(var)' to 'idx' in READ/WRITE_TLS_SLOT because idx is actually the offset ---------------

Patch Set 1 #

Total comments: 2

Patch Set 2 : replace idx with offs #

Patch Set 3 : Committed #

Unified diffs Side-by-side diffs Delta from patch set Stats (+11 lines, -11 lines) Patch
M core/unix/os.c View 1 3 chunks +11 lines, -11 lines 0 comments Download

Messages

Total messages: 5
zhaoqin
8 years, 3 months ago (2016-01-04 04:44:46 UTC) #1
bruening
Please change the variable name to "offs", as your fix looks wrong with the name ...
8 years, 3 months ago (2016-01-04 18:09:12 UTC) #2
zhaoqin
Commit log for latest patchset: --------------- fixed READ/WRITE_TLS_SLOT bug on ARM - rename idx to ...
8 years, 3 months ago (2016-01-05 16:30:57 UTC) #3
bruening
On Tue, Jan 5, 2016 at 11:30 AM, <reply@codereview-hr.appspotmail.com> wrote: > - rename idx to ...
8 years, 3 months ago (2016-01-05 16:36:46 UTC) #4
zhaoqin
8 years, 3 months ago (2016-01-05 16:57:10 UTC) #5
Committed as
https://github.com/DynamoRIO/dynamorio/commit/b914e5dadcbcc0cd937a63a1ad82f72...

Final commit log: 
---------------
fixed READ/WRITE_TLS_SLOT bug on ARM

- rename idx to offs in READ/WRITE_TLS_SLOT macros
- change 'idx * sizeof(var)' to 'offs' in READ/WRITE_TLS_SLOT

Review-URL: https://codereview.appspot.com/284080043
---------------
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b