Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(201)

Issue 27095: unittest test skipping (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
13 years, 1 month ago by Benjamin
Modified:
12 years, 9 months ago
Reviewers:
Antoine Pitrou
Base URL:
http://svn.python.org/view/*checkout*/python/trunk/
Visibility:
Public.

Patch Set 1 #

Total comments: 5

Patch Set 2 : takes into account Antoine's review #

Unified diffs Side-by-side diffs Delta from patch set Stats (+313 lines, -21 lines) Patch
M Lib/test/test_unittest.py View 1 8 chunks +124 lines, -6 lines 0 comments Download
M Lib/unittest.py View 1 13 chunks +189 lines, -15 lines 0 comments Download

Messages

Total messages: 1
Antoine Pitrou
13 years, 1 month ago (2009-03-22 23:04:20 UTC) #1
Here's a (futile) review.

http://codereview.appspot.com/27095/diff/1/3
File Lib/test/test_unittest.py (right):

http://codereview.appspot.com/27095/diff/1/3#newcode2294
Line 2294: def test_skipping_behvior(self):
Looks like you chose to torture both British English and American English :)

http://codereview.appspot.com/27095/diff/1/2
File Lib/unittest.py (right):

http://codereview.appspot.com/27095/diff/1/2#newcode129
Line 129: Skip a test if the the condition is true.
One too many "the".

http://codereview.appspot.com/27095/diff/1/2#newcode144
Line 144: _unexpected_success = object()
Wouldn't it be better if this were an Exception subclass instead, like
_ExpectedFailure? Returning magic values for error status is not very elegant.

http://codereview.appspot.com/27095/diff/1/2#newcode212
Line 212: """Called when a test was expected to failure, but succeed."""
I'm not a native English speaker, but the docstring doesn't look grammatically
correct :-S

http://codereview.appspot.com/27095/diff/1/2#newcode365
Line 365: return
Couldn't setUp() also call self.skip()?
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b