Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(831)

Issue 10537043: Determining subscribers by subscription_ids (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
10 years, 11 months ago by ana.balica
Modified:
10 years, 10 months ago
Reviewers:
thomas.j.waldmann, ReimarBauer, waldi
Visibility:
Public.

Description

For more information on subscription_ids format check EP (http://etherpad.osuosl.org/moin-mail) Section 1.3 The `subscribed_items` meta was not removed ATM, since it involves a lot of other changes unrelated to current cr.

Patch Set 1 #

Total comments: 13

Patch Set 2 : #

Total comments: 24

Patch Set 3 : #

Total comments: 3

Patch Set 4 : Fix the tests and add TypeError #

Total comments: 8

Patch Set 5 : Remove redundant check #

Patch Set 6 : Remove TAG constant #

Patch Set 7 : Change create_user usage in tests #

Total comments: 4

Patch Set 8 : Define Subscriber once #

Patch Set 9 : Remove isinstance checks #

Total comments: 8

Patch Set 10 : #

Patch Set 11 : Remove redundant imports #

Unified diffs Side-by-side diffs Delta from patch set Stats (+51 lines, -0 lines) Patch
A MoinMoin/util/subscriptions.py View 1 2 3 4 5 6 7 8 9 10 1 chunk +51 lines, -0 lines 0 comments Download

Messages

Total messages: 21
waldi
https://codereview.appspot.com/10537043/diff/1/MoinMoin/storage/middleware/indexing.py File MoinMoin/storage/middleware/indexing.py (right): https://codereview.appspot.com/10537043/diff/1/MoinMoin/storage/middleware/indexing.py#newcode325 MoinMoin/storage/middleware/indexing.py:325: Why do you need the ids to be stored, ...
10 years, 11 months ago (2013-06-25 09:49:43 UTC) #1
ana.balica
https://codereview.appspot.com/10537043/diff/1/MoinMoin/storage/middleware/indexing.py File MoinMoin/storage/middleware/indexing.py (right): https://codereview.appspot.com/10537043/diff/1/MoinMoin/storage/middleware/indexing.py#newcode325 MoinMoin/storage/middleware/indexing.py:325: If ids are not stored then I can't get ...
10 years, 11 months ago (2013-06-25 10:19:03 UTC) #2
waldi
https://codereview.appspot.com/10537043/diff/1/MoinMoin/storage/middleware/indexing.py File MoinMoin/storage/middleware/indexing.py (right): https://codereview.appspot.com/10537043/diff/1/MoinMoin/storage/middleware/indexing.py#newcode325 MoinMoin/storage/middleware/indexing.py:325: On 2013/06/25 10:19:03, ana.balica wrote: > If ids are ...
10 years, 11 months ago (2013-06-25 11:32:45 UTC) #3
Thomas.J.Waldmann
https://codereview.appspot.com/10537043/diff/19001/MoinMoin/constants/keys.py File MoinMoin/constants/keys.py (right): https://codereview.appspot.com/10537043/diff/19001/MoinMoin/constants/keys.py#newcode33 MoinMoin/constants/keys.py:33: TAG = u"tag" ehrm, can we change tags to ...
10 years, 11 months ago (2013-06-25 22:26:12 UTC) #4
ana.balica
https://codereview.appspot.com/10537043/diff/19001/MoinMoin/constants/keys.py File MoinMoin/constants/keys.py (right): https://codereview.appspot.com/10537043/diff/19001/MoinMoin/constants/keys.py#newcode70 MoinMoin/constants/keys.py:70: SUBSCRIBED_ITEMS = u"subscribed_items" right. but not at the moment. ...
10 years, 11 months ago (2013-06-26 08:51:18 UTC) #5
Thomas.J.Waldmann
https://codereview.appspot.com/10537043/diff/19001/MoinMoin/util/_tests/test_subscriptions.py File MoinMoin/util/_tests/test_subscriptions.py (right): https://codereview.appspot.com/10537043/diff/19001/MoinMoin/util/_tests/test_subscriptions.py#newcode44 MoinMoin/util/_tests/test_subscriptions.py:44: assert u1.profile._meta[ITEMID] in subscribers_itemids On 2013/06/26 08:51:19, ana.balica wrote: ...
10 years, 11 months ago (2013-06-26 09:47:54 UTC) #6
ana.balica
https://codereview.appspot.com/10537043/diff/29001/MoinMoin/util/subscriptions.py File MoinMoin/util/subscriptions.py (right): https://codereview.appspot.com/10537043/diff/29001/MoinMoin/util/subscriptions.py#newcode24 MoinMoin/util/subscriptions.py:24: :rtype set return type. or remove it?
10 years, 11 months ago (2013-06-26 12:23:43 UTC) #7
Thomas.J.Waldmann
https://codereview.appspot.com/10537043/diff/38001/MoinMoin/constants/keys.py File MoinMoin/constants/keys.py (right): https://codereview.appspot.com/10537043/diff/38001/MoinMoin/constants/keys.py#newcode33 MoinMoin/constants/keys.py:33: TAG = u"tag" hmm, another idea for that: instead ...
10 years, 10 months ago (2013-06-27 19:55:29 UTC) #8
ana.balica
https://codereview.appspot.com/10537043/diff/38001/MoinMoin/constants/keys.py File MoinMoin/constants/keys.py (right): https://codereview.appspot.com/10537043/diff/38001/MoinMoin/constants/keys.py#newcode33 MoinMoin/constants/keys.py:33: TAG = u"tag" It's a bit unclear to me. ...
10 years, 10 months ago (2013-06-27 20:20:05 UTC) #9
Thomas.J.Waldmann
https://codereview.appspot.com/10537043/diff/38001/MoinMoin/constants/keys.py File MoinMoin/constants/keys.py (right): https://codereview.appspot.com/10537043/diff/38001/MoinMoin/constants/keys.py#newcode33 MoinMoin/constants/keys.py:33: TAG = u"tag" yes https://codereview.appspot.com/10537043/diff/38001/MoinMoin/util/subscriptions.py File MoinMoin/util/subscriptions.py (right): https://codereview.appspot.com/10537043/diff/38001/MoinMoin/util/subscriptions.py#newcode57 ...
10 years, 10 months ago (2013-06-27 20:49:56 UTC) #10
waldi
https://codereview.appspot.com/10537043/diff/52001/MoinMoin/util/subscriptions.py File MoinMoin/util/subscriptions.py (right): https://codereview.appspot.com/10537043/diff/52001/MoinMoin/util/subscriptions.py#newcode27 MoinMoin/util/subscriptions.py:27: raise TypeError("item should be an instance of MoinMoin.items.Item") Why ...
10 years, 10 months ago (2013-06-29 13:30:28 UTC) #11
ana.balica
https://codereview.appspot.com/10537043/diff/52001/MoinMoin/util/subscriptions.py File MoinMoin/util/subscriptions.py (right): https://codereview.appspot.com/10537043/diff/52001/MoinMoin/util/subscriptions.py#newcode27 MoinMoin/util/subscriptions.py:27: raise TypeError("item should be an instance of MoinMoin.items.Item") To ...
10 years, 10 months ago (2013-06-30 09:47:41 UTC) #12
waldi
On 2013/06/30 09:47:41, ana.balica wrote: > MoinMoin/util/subscriptions.py:27: raise TypeError("item should be an instance > of ...
10 years, 10 months ago (2013-07-01 21:15:33 UTC) #13
ana.balica
On 2013/07/01 21:15:33, waldi wrote: > In Python we use duck-typing. So please explain why ...
10 years, 10 months ago (2013-07-01 21:48:04 UTC) #14
ReimarBauer
https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscriptions.py File MoinMoin/util/subscriptions.py (right): https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscriptions.py#newcode20 MoinMoin/util/subscriptions.py:20: Subscriber = namedtuple('Subscriber', [ITEMID, NAME, EMAIL, LOCALE]) PEP8 uppercase ...
10 years, 10 months ago (2013-07-02 08:13:46 UTC) #15
ana.balica
https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscriptions.py File MoinMoin/util/subscriptions.py (right): https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscriptions.py#newcode20 MoinMoin/util/subscriptions.py:20: Subscriber = namedtuple('Subscriber', [ITEMID, NAME, EMAIL, LOCALE]) you mean ...
10 years, 10 months ago (2013-07-02 08:20:47 UTC) #16
ReimarBauer
https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscriptions.py File MoinMoin/util/subscriptions.py (right): https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscriptions.py#newcode20 MoinMoin/util/subscriptions.py:20: Subscriber = namedtuple('Subscriber', [ITEMID, NAME, EMAIL, LOCALE]) On 2013/07/02 ...
10 years, 10 months ago (2013-07-02 09:26:06 UTC) #17
waldi
On 2013/07/02 09:26:06, ReimarBauer wrote: > https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscriptions.py > File MoinMoin/util/subscriptions.py (right): > > https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscriptions.py#newcode20 > ...
10 years, 10 months ago (2013-07-02 09:27:15 UTC) #18
ReimarBauer
https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscriptions.py File MoinMoin/util/subscriptions.py (right): https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscriptions.py#newcode43 MoinMoin/util/subscriptions.py:43: def extract_users_info(results): results is a rather generic name, can ...
10 years, 10 months ago (2013-07-02 09:33:56 UTC) #19
ana.balica
https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscriptions.py File MoinMoin/util/subscriptions.py (right): https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscriptions.py#newcode43 MoinMoin/util/subscriptions.py:43: def extract_users_info(results): On 2013/07/02 09:33:57, ReimarBauer wrote: > results ...
10 years, 10 months ago (2013-07-02 09:40:51 UTC) #20
ReimarBauer
10 years, 10 months ago (2013-07-02 09:48:36 UTC) #21
https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscription...
File MoinMoin/util/subscriptions.py (right):

https://codereview.appspot.com/10537043/diff/61001/MoinMoin/util/subscription...
MoinMoin/util/subscriptions.py:50: users = {Subscriber(result[ITEMID],
result[NAME][0], result[EMAIL], result[LOCALE])
On 2013/07/02 09:40:51, ana.balica wrote:
> On 2013/07/02 09:33:57, ReimarBauer wrote:
> > only the first name of the list?
> 
> Yep, that question was discussed and it was decided to keep just the first
name.
> 

add a comment about this there. It helps remembering this in some months.
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b