Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(2602)

Issue 6828043: Some improvements to reduce the number of pixels touched in generating alpha clip masks (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
12 years, 1 month ago by bsalomon
Modified:
12 years, 1 month ago
Reviewers:
reed1, robertphillips, TomH
CC:
skia-review_googlegroups.com
Base URL:
http://skia.googlecode.com/svn/trunk/
Visibility:
Public.

Description

Some improvements to reduce the number of pixels touched in generating alpha clip masks Committed: https://code.google.com/p/skia/source/detail?r=6329

Patch Set 1 #

Patch Set 2 : #

Patch Set 3 : #

Total comments: 15

Patch Set 4 : #

Patch Set 5 : #

Unified diffs Side-by-side diffs Delta from patch set Stats (+193 lines, -79 lines) Patch
M include/core/SkClipStack.h View 1 2 3 4 1 chunk +5 lines, -0 lines 0 comments Download
M include/core/SkMatrix.h View 1 2 3 1 chunk +2 lines, -0 lines 0 comments Download
M include/core/SkRandom.h View 1 chunk +1 line, -1 line 0 comments Download
M include/core/SkRect.h View 1 chunk +9 lines, -0 lines 0 comments Download
M src/core/SkClipStack.cpp View 1 1 chunk +9 lines, -0 lines 0 comments Download
M src/gpu/GrClipMaskManager.h View 1 2 1 chunk +5 lines, -2 lines 0 comments Download
M src/gpu/GrClipMaskManager.cpp View 1 2 3 8 chunks +60 lines, -49 lines 0 comments Download
M src/gpu/SkGpuDevice.cpp View 1 chunk +5 lines, -1 line 0 comments Download
M src/gpu/effects/GrTextureDomainEffect.h View 1 2 chunks +44 lines, -7 lines 0 comments Download
M src/gpu/effects/GrTextureDomainEffect.cpp View 1 2 3 3 chunks +53 lines, -19 lines 0 comments Download

Messages

Total messages: 9
bsalomon
12 years, 1 month ago (2012-11-07 13:51:42 UTC) #1
TomH
I think your title should be "Towards some improvements..." And the abstract needs more work.
12 years, 1 month ago (2012-11-07 13:57:07 UTC) #2
robertphillips
LGTM + 3 documentation suggestions & 1 question https://codereview.appspot.com/6828043/diff/4001/include/core/SkMatrix.h File include/core/SkMatrix.h (right): https://codereview.appspot.com/6828043/diff/4001/include/core/SkMatrix.h#newcode175 include/core/SkMatrix.h:175: void ...
12 years, 1 month ago (2012-11-07 14:23:55 UTC) #3
reed1
https://codereview.appspot.com/6828043/diff/4001/include/core/SkClipStack.h File include/core/SkClipStack.h (right): https://codereview.appspot.com/6828043/diff/4001/include/core/SkClipStack.h#newcode140 include/core/SkClipStack.h:140: const SkRect& getBounds() const; Perhaps a LF between the ...
12 years, 1 month ago (2012-11-07 14:45:48 UTC) #4
bsalomon
https://codereview.appspot.com/6828043/diff/4001/include/core/SkMatrix.h File include/core/SkMatrix.h (right): https://codereview.appspot.com/6828043/diff/4001/include/core/SkMatrix.h#newcode175 include/core/SkMatrix.h:175: void setTranslate(SkScalar dx, SkScalar dy); On 2012/11/07 14:23:55, robertphillips ...
12 years, 1 month ago (2012-11-07 14:49:12 UTC) #5
bsalomon
https://codereview.appspot.com/6828043/diff/4001/include/core/SkClipStack.h File include/core/SkClipStack.h (right): https://codereview.appspot.com/6828043/diff/4001/include/core/SkClipStack.h#newcode140 include/core/SkClipStack.h:140: const SkRect& getBounds() const; On 2012/11/07 14:45:48, reed1 wrote: ...
12 years, 1 month ago (2012-11-07 14:55:46 UTC) #6
reed1
I like MakeFromFoo or Make, more than MakeFoo. Perhaps both as aliases. e.g. SkIRect MakeFromIRect(rect) ...
12 years, 1 month ago (2012-11-07 16:12:51 UTC) #7
reed1
Of course, we can go down the operator-overloading path, and just make it all magical... ...
12 years, 1 month ago (2012-11-07 16:13:30 UTC) #8
bsalomon
12 years, 1 month ago (2012-11-07 16:14:43 UTC) #9
On 2012/11/07 16:13:30, reed1 wrote:
> Of course, we can go down the operator-overloading path, and just make it all
> magical... but I'm not sure I'm ready for that much excitement.

Yeah, My hesitation about Make() is that it may be harder to read in some
contexts where it isn't obvious what the type of the passed value is.

I'll update this CL to add MakeFromIRect() rather than MakeIRect().
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b