Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(273)

Issue 6615073: Add utility to convert skp files to pdf files. (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
11 years, 8 months ago by edisonn
Modified:
11 years, 8 months ago
Reviewers:
epoger, EricB
CC:
skia-review_googlegroups.com
Base URL:
http://skia.googlecode.com/svn/trunk/
Visibility:
Public.

Description

Add utility to convert skp files to pdf files. Code compatible with render_pictures_main.cpp. I could have refactored the code to avoid code duplication, but it does not seem right, and it will overcomplicate the code. Committed: https://code.google.com/p/skia/source/detail?r=6253

Patch Set 1 #

Patch Set 2 : #

Total comments: 24

Patch Set 3 : #

Total comments: 4

Patch Set 4 : #

Patch Set 5 : #

Total comments: 2

Patch Set 6 : #

Unified diffs Side-by-side diffs Delta from patch set Stats (+232 lines, -0 lines) Patch
M gyp/tools.gyp View 1 2 1 chunk +21 lines, -0 lines 0 comments Download
A tools/render_pdfs_main.cpp View 1 2 3 4 5 1 chunk +211 lines, -0 lines 0 comments Download

Messages

Total messages: 12
edisonn
11 years, 8 months ago (2012-10-10 19:14:10 UTC) #1
edisonn
I forgot to include this file in the previous cl.
11 years, 8 months ago (2012-10-25 14:41:23 UTC) #2
epoger
https://codereview.appspot.com/6615073/diff/3001/gyp/tools.gyp File gyp/tools.gyp (right): https://codereview.appspot.com/6615073/diff/3001/gyp/tools.gyp#newcode123 gyp/tools.gyp:123: 'target_name': 'render_pdfs', Other developers who look here will probably ...
11 years, 8 months ago (2012-10-25 15:39:55 UTC) #3
edisonn
That what I deserve for not using svn cp. This is a modified version of ...
11 years, 8 months ago (2012-10-26 02:24:33 UTC) #4
epoger
On 2012/10/26 02:24:33, edisonn wrote: > That what I deserve for not using svn cp. ...
11 years, 8 months ago (2012-10-29 09:47:19 UTC) #5
epoger
On 2012/10/29 09:47:19, epoger wrote: > On 2012/10/26 02:24:33, edisonn wrote: > > That what ...
11 years, 8 months ago (2012-10-29 09:58:04 UTC) #6
edisonn
Even if the structure of the render_* files is similar, it does not make sense ...
11 years, 8 months ago (2012-10-31 15:27:33 UTC) #7
edisonn
https://codereview.appspot.com/6615073/diff/3001/gyp/tools.gyp File gyp/tools.gyp (right): https://codereview.appspot.com/6615073/diff/3001/gyp/tools.gyp#newcode123 gyp/tools.gyp:123: 'target_name': 'render_pdfs', Done 1) On 2012/10/25 15:39:56, epoger wrote: ...
11 years, 8 months ago (2012-11-01 15:28:53 UTC) #8
epoger
https://codereview.appspot.com/6615073/diff/12001/tools/render_pdfs_main.cpp File tools/render_pdfs_main.cpp (right): https://codereview.appspot.com/6615073/diff/12001/tools/render_pdfs_main.cpp#newcode29 tools/render_pdfs_main.cpp:29: static const char PDF_FILE_EXTENTION[] = "pdf"; spelling throughout: extention ...
11 years, 8 months ago (2012-11-01 15:58:40 UTC) #9
edisonn
https://codereview.appspot.com/6615073/diff/12001/tools/render_pdfs_main.cpp File tools/render_pdfs_main.cpp (right): https://codereview.appspot.com/6615073/diff/12001/tools/render_pdfs_main.cpp#newcode29 tools/render_pdfs_main.cpp:29: static const char PDF_FILE_EXTENTION[] = "pdf"; On 2012/11/01 15:58:40, ...
11 years, 8 months ago (2012-11-01 17:04:37 UTC) #10
epoger
LGTM One optional thing... https://codereview.appspot.com/6615073/diff/18001/tools/render_pdfs_main.cpp File tools/render_pdfs_main.cpp (right): https://codereview.appspot.com/6615073/diff/18001/tools/render_pdfs_main.cpp#newcode60 tools/render_pdfs_main.cpp:60: return false; Optional: It's a ...
11 years, 8 months ago (2012-11-01 19:46:44 UTC) #11
edisonn
11 years, 8 months ago (2012-11-01 19:52:01 UTC) #12
https://codereview.appspot.com/6615073/diff/18001/tools/render_pdfs_main.cpp
File tools/render_pdfs_main.cpp (right):

https://codereview.appspot.com/6615073/diff/18001/tools/render_pdfs_main.cpp#...
tools/render_pdfs_main.cpp:60: return false;
On 2012/11/01 19:46:44, epoger wrote:
> Optional: It's a little strange that the function modifies the path even in
the
> failure case.  ("filename.skp" -> "filename.pdf", but "filenameskp" ->
> "filename")
> 
> I think it would be a good idea to either document that ("if false is
returned,
> contents of path are undefined") or change it (only modify path if successful)

Done.
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b