I removed skia-review from this CL for now. I wanted to submit something so you ...
12 years, 4 months ago
(2012-07-23 21:55:14 UTC)
#1
I removed skia-review from this CL for now. I wanted to submit something so you
can see I've made some progress.
After a ton of tinkering it looks like I was able to smash openGL into this Qt
window. It has ALOT of bugs and doesn't work for every other skia picture (don't
know why).
After sitting down and talking with both Brian and Rob we've decided the next
route of action is to hook up the stepping functionality of the debugger, the
deleting and saving to a skpicture to debug what's going on behind the scenes
with this GL stuff.
Replied to comments, CL isn't updated yet. http://codereview.appspot.com/6422060/diff/1/debugger/QT/SkDebuggerGUI.cpp File debugger/QT/SkDebuggerGUI.cpp (right): http://codereview.appspot.com/6422060/diff/1/debugger/QT/SkDebuggerGUI.cpp#newcode536 debugger/QT/SkDebuggerGUI.cpp:536: fCanvasWidget.loadPicture(fileName); On ...
12 years, 4 months ago
(2012-07-24 13:58:58 UTC)
#3
Replied to comments, CL isn't updated yet.
http://codereview.appspot.com/6422060/diff/1/debugger/QT/SkDebuggerGUI.cpp
File debugger/QT/SkDebuggerGUI.cpp (right):
http://codereview.appspot.com/6422060/diff/1/debugger/QT/SkDebuggerGUI.cpp#ne...
debugger/QT/SkDebuggerGUI.cpp:536: fCanvasWidget.loadPicture(fileName);
On 2012/07/24 03:52:25, DerekS wrote:
> seems like we should rename fCanvasWidget to fRasterWidget. Even better we
could
> create a wrapper class that encapsulates them both and then the caller doesn't
> care which one he gets.
Absolutely, today might finally be the day the great refactor has come
http://codereview.appspot.com/6422060/diff/1/debugger/QT/SkGLWidget.h
File debugger/QT/SkGLWidget.h (right):
http://codereview.appspot.com/6422060/diff/1/debugger/QT/SkGLWidget.h#newcode32
debugger/QT/SkGLWidget.h:32: debugCanvas->drawTo(fCanvas,
debugCanvas->getSize(), &temp);
On 2012/07/24 03:52:25, DerekS wrote:
> seems like this drawTo() should be in the paintGL method. However to do that
> you would need to store a pointer to the debug canvas in your class. Would
> storing the ptr be acceptable?
I've been thinking about this and am wondering if that would perhaps not slow
down performance? I am assuming paintGL is triggered over and over again and it
just displays whatever is drawn to that render target onto the screen.
The canvas only needs to be updated once per new command scrolling or picture
loading. To me that makes it seem like it would be more logical to keep it out
of paintGL since that would force redraws even when unnecessary?
http://codereview.appspot.com/6422060/diff/1/debugger/QT/SkGLWidget.h File debugger/QT/SkGLWidget.h (right): http://codereview.appspot.com/6422060/diff/1/debugger/QT/SkGLWidget.h#newcode32 debugger/QT/SkGLWidget.h:32: debugCanvas->drawTo(fCanvas, debugCanvas->getSize(), &temp); My understanding of paintGL() is that ...
12 years, 4 months ago
(2012-07-24 14:55:18 UTC)
#4
http://codereview.appspot.com/6422060/diff/1/debugger/QT/SkGLWidget.h
File debugger/QT/SkGLWidget.h (right):
http://codereview.appspot.com/6422060/diff/1/debugger/QT/SkGLWidget.h#newcode32
debugger/QT/SkGLWidget.h:32: debugCanvas->drawTo(fCanvas,
debugCanvas->getSize(), &temp);
My understanding of paintGL() is that is only called when you notify the widget
that you want it to change it's contents by calling updateGL(). In most
platforms behave this way and to constantly animate you set some draw flag or
just continuously call updateGL().
On 2012/07/24 13:58:58, chudy wrote:
> On 2012/07/24 03:52:25, DerekS wrote:
> > seems like this drawTo() should be in the paintGL method. However to do
that
> > you would need to store a pointer to the debug canvas in your class. Would
> > storing the ptr be acceptable?
>
> I've been thinking about this and am wondering if that would perhaps not slow
> down performance? I am assuming paintGL is triggered over and over again and
it
> just displays whatever is drawn to that render target onto the screen.
>
> The canvas only needs to be updated once per new command scrolling or picture
> loading. To me that makes it seem like it would be more logical to keep it out
> of paintGL since that would force redraws even when unnecessary?
https://codereview.appspot.com/6422060/diff/7001/debugger/QT/SkInspectorWidget.h File debugger/QT/SkInspectorWidget.h (right): https://codereview.appspot.com/6422060/diff/7001/debugger/QT/SkInspectorWidget.h#newcode58 debugger/QT/SkInspectorWidget.h:58: void setMatrix(SkMatrix matrix); why not pass them by reference?
12 years, 4 months ago
(2012-07-25 19:49:38 UTC)
#6
https://codereview.appspot.com/6422060/diff/9015/debugger/QT/SkCanvasWidget.cpp File debugger/QT/SkCanvasWidget.cpp (right): https://codereview.appspot.com/6422060/diff/9015/debugger/QT/SkCanvasWidget.cpp#newcode91 debugger/QT/SkCanvasWidget.cpp:91: fGLWidget.setScale(fScaleFactor); why not just pass the scale/translate as part ...
12 years, 4 months ago
(2012-07-26 13:55:55 UTC)
#9
Sorry about that, turns out I'm not using a monospace font http://codereview.appspot.com/6422060/diff/21002/debugger/QT/SkCanvasWidget.h File debugger/QT/SkCanvasWidget.h (right): ...
12 years, 4 months ago
(2012-07-26 19:30:25 UTC)
#14
Issue 6422060: Added OpenGL support to Debugger
(Closed)
Created 12 years, 4 months ago by chudy
Modified 12 years, 4 months ago
Reviewers: DerekS
Base URL: https://skia.googlecode.com/svn/trunk
Comments: 71