Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(2362)

Issue 5649082: Fix gir annotations. (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
12 years, 2 months ago by fujiwara
Modified:
12 years, 2 months ago
Reviewers:
shawn.p.huang, Peng
CC:
shawn.p.huang_gmail.com
Base URL:
git://github.com/ibus/ibus.git@master
Visibility:
Public.

Description

Fix gir annotations. - It seems python does not allow to use 'exec' as a variable. Renamed 'exec' property so that the constructor in IBus.Component is used. - It seems the python virtual method is available when the function is described in header files in case that annotations are needed so the signal function ibus_factory_create_engine is added newly. TEST=Linux desktop

Patch Set 1 #

Total comments: 5

Patch Set 2 : Updated with message #5. #

Unified diffs Side-by-side diffs Delta from patch set Stats (+46 lines, -21 lines) Patch
M src/ibusattribute.h View 4 chunks +4 lines, -4 lines 0 comments Download
M src/ibuscomponent.h View 1 4 chunks +4 lines, -4 lines 0 comments Download
M src/ibuscomponent.c View 1 6 chunks +10 lines, -10 lines 0 comments Download
M src/ibusfactory.h View 1 1 chunk +11 lines, -0 lines 0 comments Download
M src/ibusfactory.c View 1 3 chunks +17 lines, -3 lines 0 comments Download

Messages

Total messages: 7
fujiwara
I started to port ibus-anthy to python gtk3. This patch is needed for it.
12 years, 2 months ago (2012-02-13 11:28:44 UTC) #1
Peng
https://codereview.appspot.com/5649082/diff/1/src/ibuscomponent.c File src/ibuscomponent.c (right): https://codereview.appspot.com/5649082/diff/1/src/ibuscomponent.c#newcode37 src/ibuscomponent.c:37: PROP_EXEC_LINE, maybe rename it ro cmdline? https://codereview.appspot.com/5649082/diff/1/src/ibusfactory-private.h File src/ibusfactory-private.h ...
12 years, 2 months ago (2012-02-15 02:50:05 UTC) #2
fujiwara
On 2012/02/15 02:50:05, Peng wrote: > https://codereview.appspot.com/5649082/diff/1/src/ibuscomponent.c > File src/ibuscomponent.c (right): > > https://codereview.appspot.com/5649082/diff/1/src/ibuscomponent.c#newcode37 > ...
12 years, 2 months ago (2012-02-15 02:57:41 UTC) #3
Peng
On 2012/02/15 02:57:41, fujiwara wrote: > On 2012/02/15 02:50:05, Peng wrote: > > https://codereview.appspot.com/5649082/diff/1/src/ibuscomponent.c > ...
12 years, 2 months ago (2012-02-15 17:23:47 UTC) #4
Peng
https://codereview.appspot.com/5649082/diff/1/src/ibuscomponent.c File src/ibuscomponent.c (right): https://codereview.appspot.com/5649082/diff/1/src/ibuscomponent.c#newcode37 src/ibuscomponent.c:37: PROP_EXEC_LINE, On 2012/02/15 02:50:05, Peng wrote: > maybe rename ...
12 years, 2 months ago (2012-02-15 17:33:22 UTC) #5
fujiwara
On 2012/02/15 17:33:22, Peng wrote: > https://codereview.appspot.com/5649082/diff/1/src/ibuscomponent.c > File src/ibuscomponent.c (right): > > https://codereview.appspot.com/5649082/diff/1/src/ibuscomponent.c#newcode37 > ...
12 years, 2 months ago (2012-02-16 02:24:26 UTC) #6
Peng
12 years, 2 months ago (2012-02-16 03:21:55 UTC) #7
On 2012/02/16 02:24:26, fujiwara wrote:
> On 2012/02/15 17:33:22, Peng wrote:
> > https://codereview.appspot.com/5649082/diff/1/src/ibuscomponent.c
> > File src/ibuscomponent.c (right):
> > 
> > https://codereview.appspot.com/5649082/diff/1/src/ibuscomponent.c#newcode37
> > src/ibuscomponent.c:37: PROP_EXEC_LINE,
> > On 2012/02/15 02:50:05, Peng wrote:
> > > maybe rename it ro cmdline?
> > 
> > Please use COMMAND_LINE
> 
> Done.
> 
> > 
> > https://codereview.appspot.com/5649082/diff/1/src/ibuscomponent.c#newcode197
> > src/ibuscomponent.c:197: g_param_spec_string ("exec_line",
> > I prefer "command-line" instead of "command_line".
> > 
> > https://codereview.appspot.com/5649082/diff/1/src/ibusfactory-private.h
> > File src/ibusfactory-private.h (right):
> > 
> >
>
https://codereview.appspot.com/5649082/diff/1/src/ibusfactory-private.h#newco...
> > src/ibusfactory-private.h:48: ibus_factory_create_engine    (IBusFactory   
> > *factory,
> > I checked some doc. Seems there is not a good way to annotate a virtual
> method. 
> > But if the virtual method has emitter, maybe it will uses the emitter's
> > annotation.
> > So this header file works.
> > 
> > Could you please move this function to ibusfactory.h and make it as a
emitter
> > function?
> 
> Great. I thought the real class method would be needed but probably you're
> right. The emitter is needed for the virtual functions instead.
> I added the ibus_factory_create_engine.
> 
> BTW, I'd like to back-port this patch to ibus 1.4 too.
> I guess you might like to add '--warn-all' into IBUS_GIR_SCANNERFLAGS in
> src/Makefile.am in case of debugging.
> 
> > 
> > for example:
> > 
> > IBusEngine *ibus_factory_create_engine(...) {
> >     g_signal_emit("create-engine", ...,&retval);
> >     return retval;
> > }
> > 
> > Future tasks:
> > I think it is better to add all emitter functions for all signals.

lgtm
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b