Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(213)

Issue 5461047: code review 5461047: misc/dashboard: user interface (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
13 years, 3 months ago by adg
Modified:
13 years, 3 months ago
Reviewers:
CC:
rsc, golang-dev
Visibility:
Public.

Description

misc/dashboard: user interface

Patch Set 1 #

Patch Set 2 : diff -r fafcd328da73 https://go.googlecode.com/hg #

Patch Set 3 : diff -r eb50eca2f4d6 https://go.googlecode.com/hg #

Patch Set 4 : diff -r a9d73de3335e https://go.googlecode.com/hg #

Patch Set 5 : diff -r 533d76fb35b1 https://go.googlecode.com/hg #

Patch Set 6 : diff -r 533d76fb35b1 https://go.googlecode.com/hg #

Patch Set 7 : diff -r 533d76fb35b1 https://go.googlecode.com/hg #

Total comments: 8

Patch Set 8 : diff -r 7c8a0711cc3a https://go.googlecode.com/hg #

Total comments: 6

Patch Set 9 : diff -r f49ead115cf9 https://go.googlecode.com/hg #

Unified diffs Side-by-side diffs Delta from patch set Stats (+442 lines, -41 lines) Patch
M misc/dashboard/app/app.yaml View 1 2 3 4 1 chunk +3 lines, -1 line 0 comments Download
M misc/dashboard/app/build/build.go View 1 2 3 4 5 6 7 15 chunks +94 lines, -35 lines 0 comments Download
M misc/dashboard/app/build/test.go View 1 2 3 4 5 chunks +20 lines, -5 lines 0 comments Download
A misc/dashboard/app/build/ui.go View 1 2 3 4 5 6 7 8 1 chunk +187 lines, -0 lines 0 comments Download
A misc/dashboard/app/build/ui.html View 1 2 3 4 5 6 7 8 1 chunk +138 lines, -0 lines 0 comments Download
A misc/dashboard/app/static/status_alert.gif View 1 2 3 4 Binary file 0 comments Download
A misc/dashboard/app/static/status_good.gif View 1 2 3 4 Binary file 0 comments Download

Messages

Total messages: 5
adg
Hello golang-dev@googlegroups.com, I'd like you to review this change to https://go.googlecode.com/hg
13 years, 3 months ago (2011-12-15 05:41:08 UTC) #1
rsc
Please make a pass through and add comments. http://codereview.appspot.com/5461047/diff/11009/misc/dashboard/app/build/build.go File misc/dashboard/app/build/build.go (right): http://codereview.appspot.com/5461047/diff/11009/misc/dashboard/app/build/build.go#newcode119 misc/dashboard/app/build/build.go:119: func ...
13 years, 3 months ago (2011-12-15 16:48:29 UTC) #2
adg
PTAL Added a whole bunch of comments. http://codereview.appspot.com/5461047/diff/11009/misc/dashboard/app/build/build.go File misc/dashboard/app/build/build.go (right): http://codereview.appspot.com/5461047/diff/11009/misc/dashboard/app/build/build.go#newcode119 misc/dashboard/app/build/build.go:119: func (c ...
13 years, 3 months ago (2011-12-15 23:23:05 UTC) #3
rsc
LGTM http://codereview.appspot.com/5461047/diff/12023/misc/dashboard/app/build/ui.go File misc/dashboard/app/build/ui.go (right): http://codereview.appspot.com/5461047/diff/12023/misc/dashboard/app/build/ui.go#newcode59 misc/dashboard/app/build/ui.go:59: err = uiTemplate.Execute(w, struct { The fields get ...
13 years, 3 months ago (2011-12-15 23:33:58 UTC) #4
adg
13 years, 3 months ago (2011-12-15 23:48:16 UTC) #5
*** Submitted as http://code.google.com/p/go/source/detail?r=974a5265f6aa ***

misc/dashboard: user interface

R=rsc
CC=golang-dev
http://codereview.appspot.com/5461047

http://codereview.appspot.com/5461047/diff/12023/misc/dashboard/app/build/ui.go
File misc/dashboard/app/build/ui.go (right):

http://codereview.appspot.com/5461047/diff/12023/misc/dashboard/app/build/ui....
misc/dashboard/app/build/ui.go:59: err = uiTemplate.Execute(w, struct {
On 2011/12/15 23:33:58, rsc wrote:
> The fields get named types.  The struct should have a named type too.
> This is a monster of a statement.

Done.

http://codereview.appspot.com/5461047/diff/12023/misc/dashboard/app/build/ui....
misc/dashboard/app/build/ui.go:147: var uiTemplate =
template.Must(template.New("ui").Funcs(
On 2011/12/15 23:33:58, rsc wrote:
> how about
> 
> var uiTemplate = template.Must(
>     template.New("ui").
>         Funcs(
>             ...
>         }).
>         ParseFile("build/ui.html"),
> )
> 
> Or else make the FuncMap its own var.

Done.

http://codereview.appspot.com/5461047/diff/12023/misc/dashboard/app/build/ui....
misc/dashboard/app/build/ui.go:150: "timeString":   timeString,
On 2011/12/15 23:33:58, rsc wrote:
> A better name might be datastoreTime
> Of course, you can also write {{.T.Time}} instead of {{.T | timeString}}
> and delete the function entirely.

Done.
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b