Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(54)

Issue 2920041: draft fix for pr8419

Can't Edit
Can't Publish+Mail
Start Review
Created:
11 years, 8 months ago by wan
Modified:
7 years, 7 months ago
Reviewers:
xuzhongxing
Base URL:
http://llvm.org/svn/llvm-project/cfe/trunk/
Visibility:
Public.

Patch Set 1 #

Patch Set 2 : fix PR8419 and add comments #

Patch Set 3 : fix the symptom of PR8419 #

Total comments: 1

Patch Set 4 : improve comments in Clang static analyzer #

Unified diffs Side-by-side diffs Delta from patch set Stats (+55 lines, -32 lines) Patch
M include/clang/Checker/PathSensitive/Environment.h View 1 2 2 chunks +5 lines, -1 line 0 comments Download
M include/clang/Checker/PathSensitive/GRExprEngine.h View 2 2 chunks +5 lines, -1 line 0 comments Download
M include/clang/Checker/PathSensitive/GRState.h View 1 2 7 chunks +26 lines, -28 lines 0 comments Download
M include/clang/Checker/PathSensitive/SVals.h View 1 2 2 chunks +15 lines, -2 lines 0 comments Download
M include/clang/Checker/PathSensitive/Store.h View 2 1 chunk +4 lines, -0 lines 0 comments Download

Messages

Total messages: 2
xuzhongxing
http://codereview.appspot.com/2920041/diff/7001/lib/Analysis/CFG.cpp File lib/Analysis/CFG.cpp (right): http://codereview.appspot.com/2920041/diff/7001/lib/Analysis/CFG.cpp#newcode936 lib/Analysis/CFG.cpp:936: bool needLVal = U->isIncrementDecrementOp(); I suggest rename needLVal to ...
11 years, 7 months ago (2010-11-20 12:38:10 UTC) #1
wan
11 years, 7 months ago (2010-11-22 08:49:18 UTC) #2
Thanks for the review, Ted and Zhongxing.

I renamed the variable to asLVal, reverted the cosmetic changes, built
and ran the tests, and committed this in r119960.  Cheers,

On Sat, Nov 20, 2010 at 4:38 AM,  <xuzhongxing@gmail.com> wrote:
>
> http://codereview.appspot.com/2920041/diff/7001/lib/Analysis/CFG.cpp
> File lib/Analysis/CFG.cpp (right):
>
>
http://codereview.appspot.com/2920041/diff/7001/lib/Analysis/CFG.cpp#newcode936
> lib/Analysis/CFG.cpp:936: bool needLVal = U->isIncrementDecrementOp();
> I suggest rename needLVal to asLVal.
>
> http://codereview.appspot.com/2920041/
>



-- 
Zhanyong
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b