Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(1254)

Issue 4636065: [pph] Rename token cache and identifiers streaming functions to reflect pph naming scheme (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
13 years, 9 months ago by Gabriel Charette
Modified:
13 years, 9 months ago
CC:
gcc-patches_gcc.gnu.org
Visibility:
Public.

Patch Set 1 #

Unified diffs Side-by-side diffs Delta from patch set Stats (+31 lines, -31 lines) Patch
M gcc/cp/pph-streamer-in.c View 14 chunks +16 lines, -16 lines 0 comments Download
M gcc/cp/pph-streamer-out.c View 12 chunks +15 lines, -15 lines 0 comments Download

Messages

Total messages: 3
Gabriel Charette
Renamed all functions to reflect pph naming schemes (pph_in/out_*). Also reordered parameters so that the ...
13 years, 9 months ago (2011-06-27 20:33:26 UTC) #1
Diego Novillo
On 2011/06/27 20:33:26, Gabriel Charette wrote: > 2011-06-27 Gabriel Charette <mailto:gchare@google.com> Remove the 'mailto:' prefix. ...
13 years, 9 months ago (2011-06-27 20:40:01 UTC) #2
Gabriel Charette
13 years, 9 months ago (2011-06-27 22:26:28 UTC) #3
On Mon, Jun 27, 2011 at 1:40 PM, <dnovillo@google.com> wrote:
>
> On 2011/06/27 20:33:26, Gabriel Charette wrote:
>>
>> 2011-06-27  Gabriel Charette  <mailto:gchare@google.com>
>
> Remove the 'mailto:' prefix.

Weird, that's not in the actual patch, probably gmail putting it in...

Commited as rev r175568.

Gab


>
>
>>        * pph-streamer-in.c (pph_get_type_from_index):
>>        Rename from pth_get_type_from_index. Update all users.
>>        (pph_in_number): Rename from pth_load_number.
>>        Update all users.
>>        (pph_in_token_value): Rename from pth_load_token_value. Change
>>        signature to 'pph_stream*, cp_token*' from 'cp_token*, pph_stream*'.
>>        Update all users.
>>        (pph_in_token): Rename from pth_load_token.
>>        Update all users.
>>        (pph_in_token_cache): Rename from pth_load_token_cache.
>>        Update all users.
>>        (pph_in_identifiers): Rename from pth_load_identifiers. Change
>>        signature to 'pph_stream*, cpp_idents_used*' from
>>        'cpp_idents_used*, pph_stream*'.
>>        from (cpp_idents_used*, pph_stream*).
>>        Update all users.
>>        * pph-streamer-out.c (pph_get_index_from_type):
>>        Rename from pth_get_index_from_type.
>>        Update all users.
>>        (pph_out_number): Rename from pth_write_number.
>>        Update all users.
>>        (pph_out_token_value): Rename from pth_save_token_value.
>>        Update all users.
>>        (pph_out_token): Rename from pth_save_token. Change signature to
>>        'pph_stream*, cp_token*' from 'cp_token*, pph_stream*'.
>>        Update all users.
>>        (pph_out_token_cache): Rename from pth_save_token_cache. Change
>>        signature to 'pph_stream*, cp_token_cache*'
>>        from 'cp_token_cache*, pph_stream*'.
>>        Update all users.
>>        (pph_out_identifiers): Rename from pth_save_identifiers. Change
>>        signature to 'pph_stream*, cpp_idents_used*' from
>>        'cpp_idents_used*, pph_stream*'.
>>        Update all users.
>
> OK with that change.
>
>
> Diego.
>
> http://codereview.appspot.com/4636065/
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b