Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(7683)

Issue 324260043: Implementation of warm-ups + sync'd start times

Can't Edit
Can't Publish+Mail
Start Review
Created:
6 years, 8 months ago by w.fakher.reda
Modified:
6 years, 8 months ago
CC:
kirill.sc, w.fakher.reda
Visibility:
Public.

Description

Implementation of warm-ups + sync'd start times

Patch Set 1 #

Total comments: 23
Unified diffs Side-by-side diffs Delta from patch set Stats (+148 lines, -21 lines) Patch
M core/src/main/java/com/yahoo/ycsb/Client.java View 4 chunks +17 lines, -1 line 3 comments Download
M core/src/main/java/com/yahoo/ycsb/Workload.java View 1 chunk +1 line, -1 line 0 comments Download
M core/src/main/java/com/yahoo/ycsb/workloads/CoreWorkload.java View 2 chunks +16 lines, -3 lines 2 comments Download
M core/src/main/java/com/yahoo/ycsb/workloads/TraceWorkload.java View 5 chunks +114 lines, -16 lines 18 comments Download

Messages

Total messages: 3
kirill.sc
Hey dude, I just noticed your review on the website. I haven't received the email ...
6 years, 8 months ago (2017-08-19 19:16:20 UTC) #1
kirill.sc
see first set of comments https://codereview.appspot.com/324260043/diff/1/core/src/main/java/com/yahoo/ycsb/Client.java File core/src/main/java/com/yahoo/ycsb/Client.java (right): https://codereview.appspot.com/324260043/diff/1/core/src/main/java/com/yahoo/ycsb/Client.java#newcode389 core/src/main/java/com/yahoo/ycsb/Client.java:389: private static long sync_start_timestamp; ...
6 years, 8 months ago (2017-08-20 10:00:01 UTC) #2
kirill.sc
6 years, 8 months ago (2017-08-20 13:06:31 UTC) #3
see my last set of comments

https://codereview.appspot.com/324260043/diff/1/core/src/main/java/com/yahoo/...
File core/src/main/java/com/yahoo/ycsb/workloads/TraceWorkload.java (right):

https://codereview.appspot.com/324260043/diff/1/core/src/main/java/com/yahoo/...
core/src/main/java/com/yahoo/ycsb/workloads/TraceWorkload.java:121: long
stepinterval = warmupperiod_ns/5; //For now we statically set the step function
to have 5 steps
make 5 a global variable in this class. I would think it would make sense to
have a more gradual increase. say 20 steps or something like that. to start very
slow.

https://codereview.appspot.com/324260043/diff/1/core/src/main/java/com/yahoo/...
core/src/main/java/com/yahoo/ycsb/workloads/TraceWorkload.java:124: int stepx =
(int) (stepincrement * stepinterval/1000000000L);
do stepinterval/1000000000L once when you initialize the variable

https://codereview.appspot.com/324260043/diff/1/core/src/main/java/com/yahoo/...
core/src/main/java/com/yahoo/ycsb/workloads/TraceWorkload.java:130:
stepFunc.put(stepx, stepy);
what are the stepx and stepy?

https://codereview.appspot.com/324260043/diff/1/core/src/main/java/com/yahoo/...
core/src/main/java/com/yahoo/ycsb/workloads/TraceWorkload.java:154: public long
getDeadlineForTransaction(long startTimeNs, int opsdone, long targetOpsTickNs) {
I dont understand the input variables, what do they mean? 
Is this function being called for every request?

https://codereview.appspot.com/324260043/diff/1/core/src/main/java/com/yahoo/...
core/src/main/java/com/yahoo/ycsb/workloads/TraceWorkload.java:155: if(opsdone
>= warmupops) {
Do we guaranteed to be here synchronously between different YCSBs? Is there
anything that can prevent one of the YCSBs to come here at the same time. For
example, if one of the YCSBs using sync mode and has not sufficient threads then
it will take more time to come to the point when all warming up operations are
completed.

https://codereview.appspot.com/324260043/diff/1/core/src/main/java/com/yahoo/...
core/src/main/java/com/yahoo/ycsb/workloads/TraceWorkload.java:156: //we are
done warming up
When we are here for the first time, it would be nice to see a message in YCSB
saying, warming up is over, now starts the real deal.

https://codereview.appspot.com/324260043/diff/1/core/src/main/java/com/yahoo/...
core/src/main/java/com/yahoo/ycsb/workloads/TraceWorkload.java:172: {
be consistent with your scope brackets are they on the same line or on the next
line? I personally prefer to have them on the same line. Saves space.

https://codereview.appspot.com/324260043/diff/1/core/src/main/java/com/yahoo/...
core/src/main/java/com/yahoo/ycsb/workloads/TraceWorkload.java:173: if(opsdone >
stepopcount) {
these two if statements are very difficult to read. 
Why do we have to iterate over stepFunc? can't we just know where we are based
on the time since the start or the number of operations we have sent?

https://codereview.appspot.com/324260043/diff/1/core/src/main/java/com/yahoo/...
core/src/main/java/com/yahoo/ycsb/workloads/TraceWorkload.java:202: double
targetperthread = ((double) target) / ((double) threadcount);
targetperthread -> targetSendingRatePerThreadPerSecond  ??

https://codereview.appspot.com/324260043/diff/1/core/src/main/java/com/yahoo/...
core/src/main/java/com/yahoo/ycsb/workloads/TraceWorkload.java:206: return
targetOpsTickNs;
what is this value targetOpsTickNs ? is this how much each thread will wait
until sending a new request?
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b