http://codereview.appspot.com/6277044/diff/1/asan_rtl.cc File asan_rtl.cc (right): http://codereview.appspot.com/6277044/diff/1/asan_rtl.cc#newcode55 asan_rtl.cc:55: bool FLAG_use_internal_symbolizer = 0; we already have FLAG_symbolize for exactly this purpose. http://codereview.appspot.com/6277044/diff/1/asan_stack.cc File asan_stack.cc (right): http://codereview.appspot.com/6277044/diff/1/asan_stack.cc#newcode56 asan_stack.cc:56: Printf(" #%zu 0x%zx %s:%d:%d\n", frame_num++, pc, i'd prefer to have frame_num++ in a separate line http://codereview.appspot.com/6277044/diff/1/asan_stack.cc#newcode65 asan_stack.cc:65: Printf(" #%zu 0x%zx (%s+0x%zx)\n", frame_num++, pc, filename, same here, or just use 'i'
http://codereview.appspot.com/6277044/diff/1/asan_rtl.cc File asan_rtl.cc (right): http://codereview.appspot.com/6277044/diff/1/asan_rtl.cc#newcode55 asan_rtl.cc:55: bool FLAG_use_internal_symbolizer = 0; On 2012/06/04 10:27:21, kcc1 wrote: > we already have FLAG_symbolize for exactly this purpose. Indeed :). Removed new flag. http://codereview.appspot.com/6277044/diff/1/asan_stack.cc File asan_stack.cc (right): http://codereview.appspot.com/6277044/diff/1/asan_stack.cc#newcode56 asan_stack.cc:56: Printf(" #%zu 0x%zx %s:%d:%d\n", frame_num++, pc, On 2012/06/04 10:27:21, kcc1 wrote: > i'd prefer to have frame_num++ in a separate line Done. http://codereview.appspot.com/6277044/diff/1/asan_stack.cc#newcode65 asan_stack.cc:65: Printf(" #%zu 0x%zx (%s+0x%zx)\n", frame_num++, pc, filename, On 2012/06/04 10:27:21, kcc1 wrote: > same here, or just use 'i' Done.
LGTM http://codereview.appspot.com/6277044/diff/5001/asan_stack.cc File asan_stack.cc (right): http://codereview.appspot.com/6277044/diff/5001/asan_stack.cc#newcode54 asan_stack.cc:54: while (entry) { I'd actually prefer a 'for' loop here.
r157924 http://codereview.appspot.com/6277044/diff/5001/asan_stack.cc File asan_stack.cc (right): http://codereview.appspot.com/6277044/diff/5001/asan_stack.cc#newcode54 asan_stack.cc:54: while (entry) { On 2012/06/04 11:11:09, kcc1 wrote: > I'd actually prefer a 'for' loop here. Done.