LGTM http://codereview.appspot.com/6116047/diff/1/include/gpu/GrClip.h File include/gpu/GrClip.h (left): http://codereview.appspot.com/6116047/diff/1/include/gpu/GrClip.h#oldcode63 include/gpu/GrClip.h:63: GrSetOp getOp(int i) const { return fList[i].fOp; } I sometimes use a typedef when using a nested type from one class in another. E.g. typedef SkRegion::Op Op; Just FYI that it's ok style-wise. I don't know that I'd do it in this case but sometimes the scoped name is really long and repeated many times.
committed as r3763