Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(303)

Issue 5836047: GPU blit speedup: avoid texture filtering and texture domain when not necessary (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
12 years, 5 months ago by junov1
Modified:
12 years, 5 months ago
CC:
senorblanco, skia-review_googlegroups.com
Base URL:
http://skia.googlecode.com/svn/trunk/
Visibility:
Public.

Description

Closed with r3421

Patch Set 1 #

Patch Set 2 : try2 #

Total comments: 5

Patch Set 3 : unsmellification #

Total comments: 4

Patch Set 4 : readability improvement #

Total comments: 1

Patch Set 5 : improve readability of mayColorBleed() and fixed use of canvas transform matrix #

Total comments: 2
Unified diffs Side-by-side diffs Delta from patch set Stats (+79 lines, -8 lines) Patch
M src/gpu/SkGpuDevice.cpp View 1 2 3 4 4 chunks +79 lines, -8 lines 2 comments Download

Messages

Total messages: 11
junov1
Significant bitmap blit speedup for common use cases in GPU rendering path. By being more ...
12 years, 5 months ago (2012-03-15 18:47:49 UTC) #1
TomH
http://codereview.appspot.com/5836047/diff/2001/src/gpu/SkGpuDevice.cpp File src/gpu/SkGpuDevice.cpp (right): http://codereview.appspot.com/5836047/diff/2001/src/gpu/SkGpuDevice.cpp#newcode1267 src/gpu/SkGpuDevice.cpp:1267: if (m.rectStaysRect() && useFiltering) { Great low-level comments through ...
12 years, 5 months ago (2012-03-15 18:53:54 UTC) #2
Stephen White
http://codereview.appspot.com/5836047/diff/2001/src/gpu/SkGpuDevice.cpp File src/gpu/SkGpuDevice.cpp (right): http://codereview.appspot.com/5836047/diff/2001/src/gpu/SkGpuDevice.cpp#newcode57 src/gpu/SkGpuDevice.cpp:57: // This constant represents the screen alignment criterion for ...
12 years, 5 months ago (2012-03-15 19:25:34 UTC) #3
bsalomon
Maybe a way of addressing Tom and Stephen's comments would be to break the new ...
12 years, 5 months ago (2012-03-15 19:38:16 UTC) #4
Stephen White
On 2012/03/15 19:38:16, bsalomon wrote: > Maybe a way of addressing Tom and Stephen's comments ...
12 years, 5 months ago (2012-03-15 19:51:14 UTC) #5
junov1
New patch.
12 years, 5 months ago (2012-03-15 20:22:21 UTC) #6
Stephen White
http://codereview.appspot.com/5836047/diff/3/src/gpu/SkGpuDevice.cpp File src/gpu/SkGpuDevice.cpp (right): http://codereview.appspot.com/5836047/diff/3/src/gpu/SkGpuDevice.cpp#newcode1349 src/gpu/SkGpuDevice.cpp:1349: bool needsTextureDomain = false; I would actually invert this ...
12 years, 5 months ago (2012-03-15 20:49:28 UTC) #7
junov1
New patch.
12 years, 5 months ago (2012-03-15 21:40:52 UTC) #8
bsalomon
Mostly LGTM. Do you think there would be an advantage to doing the checks outside ...
12 years, 5 months ago (2012-03-16 13:14:32 UTC) #9
junov1
On 2012/03/16 13:14:32, bsalomon wrote: > Mostly LGTM. Do you think there would be an ...
12 years, 5 months ago (2012-03-16 14:03:59 UTC) #10
bsalomon
12 years, 5 months ago (2012-03-16 14:17:36 UTC) #11
Some trivial comments below that you can commit with or without as far as I'm
concerned. So LGTM.

http://codereview.appspot.com/5836047/diff/8002/src/gpu/SkGpuDevice.cpp
File src/gpu/SkGpuDevice.cpp (right):

http://codereview.appspot.com/5836047/diff/8002/src/gpu/SkGpuDevice.cpp#newco...
src/gpu/SkGpuDevice.cpp:1272: // So we can assume that sampling is axis aligned
but not texel aligned.
Want to stick an assert here GrAssert(!hasAlignedSamples(srcrect,
transformedRect))?

http://codereview.appspot.com/5836047/diff/8002/src/gpu/SkGpuDevice.cpp#newco...
src/gpu/SkGpuDevice.cpp:1340: bool needsTextureDomain;
very minor comment: would it improve readability to set needsTextureDomain=false
here rather than have the else clause?  I assume that either the overhead of
double setting is not worth worrying about or that the compiler can effectively
turn it into an else.

It would match the flow below with textureDomain set initially empty
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b