This touches a bunch of files but has very trivial changes.
There are two changes:
1. Remove GrDrawTarget::StageBitfield and replace with GrDrawState::StageMask.
Also, in some places we were using int rather than the named type and those are
replaced by StageMask.
2. I'm applying a naming convention that I intend to use for GrDrawState to
GrPaint. My planned pattern for GrDrawState to differentiate accessors that
allow writable access to members from the usual read-only access is as follows:
A. read-only accessors use "get" in the name and return by value for small
types or const ref for large types.
B. writable accessors don't use "get" in the name and return a non-const ptr.
Issue 5437138: Prep for making GrDrawState a class
(Closed)
Created 13 years ago by bsalomon
Modified 13 years ago
Reviewers: TomH
Base URL: http://skia.googlecode.com/svn/trunk/
Comments: 0