Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(16359)

Issue 3264041: add rule for naming type/function/variable to the coding standards

Can't Edit
Can't Publish+Mail
Start Review
Created:
13 years, 5 months ago by wan
Modified:
13 years, 5 months ago
Reviewers:
chandlerc
Base URL:
https://llvm.org/svn/llvm-project/llvm/trunk/
Visibility:
Public.

Patch Set 1 #

Total comments: 1

Patch Set 2 : add an exception about short local variable names #

Patch Set 3 : addresses Chris' comments. #

Unified diffs Side-by-side diffs Delta from patch set Stats (+67 lines, -0 lines) Patch
M docs/CodingStandards.html View 1 2 2 chunks +67 lines, -0 lines 0 comments Download

Messages

Total messages: 1
chandlerc
13 years, 5 months ago (2010-11-23 05:27:58 UTC) #1
http://codereview.appspot.com/3264041/diff/1/docs/CodingStandards.html
File docs/CodingStandards.html (right):

http://codereview.appspot.com/3264041/diff/1/docs/CodingStandards.html#newcod...
docs/CodingStandards.html:801: camel case (e.g. <tt>TextFileReader</tt> and
<tt>isLValue</tt>).
I would really prefer some stylistic difference between variables and
types/functions. This is mostly a problem (for me) with local variables, where
having some signifier of the locality helps me in reading it.

The most common style I have worked with is to use under_score_separators for
variables. Personally, I would advocate for sharing this style with member
variables as well, but those aren't as important to me when reading code.
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b