Here's a (futile) review. http://codereview.appspot.com/27095/diff/1/3 File Lib/test/test_unittest.py (right): http://codereview.appspot.com/27095/diff/1/3#newcode2294 Line 2294: def test_skipping_behvior(self): Looks like you chose to torture both British English and American English :) http://codereview.appspot.com/27095/diff/1/2 File Lib/unittest.py (right): http://codereview.appspot.com/27095/diff/1/2#newcode129 Line 129: Skip a test if the the condition is true. One too many "the". http://codereview.appspot.com/27095/diff/1/2#newcode144 Line 144: _unexpected_success = object() Wouldn't it be better if this were an Exception subclass instead, like _ExpectedFailure? Returning magic values for error status is not very elegant. http://codereview.appspot.com/27095/diff/1/2#newcode212 Line 212: """Called when a test was expected to failure, but succeed.""" I'm not a native English speaker, but the docstring doesn't look grammatically correct :-S http://codereview.appspot.com/27095/diff/1/2#newcode365 Line 365: return Couldn't setUp() also call self.skip()?